- cross-posted to:
- programmerhumor@lemmy.ml
- cross-posted to:
- programmerhumor@lemmy.ml
Which is why making code readable is so very important. Our juniors and students will think we’re ridiculous, when we spend a long time cleaning up some code or choosing the least misunderstandable name for a type. But you fuck that up and then others, as well as your future self, will be wasting many more minutes misunderstanding what your code does.
The people who say “the code is the documentation” totally misunderstood what that was supposed to look like
You dont. Thats why you write comments!
It’s thing! Omni-man says ‘thing’, not ‘part’. I’ve seen this meme format for a few years now and I’ve only just realised it’s a misquote after watching the show. Completely irrelevant nitpick I know but some people might appreciate it.
Comment your code. Problem solved.
And decent variable names if you can, as well.
No magic numbers!
WYM, I can’t just name my functions
foo()
and my variables single letters? /s